aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb')
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb
new file mode 100644
index 0000000000..78cbba6b27
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.15.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Python bindings for the Apache Thrift RPC system"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
+
+SRC_URI[sha256sum] = "87c8205a71cf8bbb111cb99b1f7495070fbc9cabb671669568854210da5b3e29"
+
+inherit pypi setuptools3
+
+# Use different filename to prevent conflicts with thrift itself
+PYPI_SRC_URI:append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"