aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone_git.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb
index 7eae12a8bf..5ff753eda6 100644
--- a/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb
@@ -3,14 +3,13 @@ LICENSE = "AGPL-3.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
-PV = "1.2"
-SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6"
-SRC_URI = "git://github.com/liftoff/GateOne.git \
- file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
+PV = "1.2+git${SRCPV}"
+SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
+SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
file://gateone-avahi.service \
- file://80oe.conf \
- file://gateone.service \
- file://gateone-init \
+ file://80oe.conf.in \
+ file://gateone.service.in \
+ file://gateone-init.in \
"
S = "${WORKDIR}/git"
@@ -28,7 +27,12 @@ DISTUTILS_INSTALL_ARGS = "--root=${D} \
do_install_append() {
# fix up hardcoded paths
- sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service
+ for file in gateone.service gateone-init 80oe.conf; do
+ sed -e s:@bindir@:${bindir}:g \
+ -e s:@localstate@:${localstatedir}:g \
+ < ${WORKDIR}/$file.in \
+ > ${WORKDIR}/$file
+ done
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
@@ -49,6 +53,7 @@ FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYT
RDEPENDS_${PN} = "mime-support \
openssh-ssh \
python-compression \
+ python-contextlib \
python-crypt \
python-datetime \
python-email \
@@ -76,6 +81,7 @@ RDEPENDS_${PN} = "mime-support \
python-tornado \
python-unixadmin \
python-xml \
+ python-html5lib \
bash \
"