aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb23
1 files changed, 3 insertions, 20 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
index d986da9043..13479a90fe 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -17,26 +17,9 @@ SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6
S = "${WORKDIR}/${BPN}_${PV}"
do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${S}/bin/* ${D}${bindir}
-}
-
-# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
-EXTRA_OEMAKE_class-native = "all3"
-
-do_install_class-native() {
- install -d ${D}${bindir}
- install -d ${D}${bindir}/Codecs
- install -m 0755 ${S}/bin/7* ${D}${bindir}
- install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
-
- # Create a shell script wrapper to execute next to 7z.so
- mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
- cat > ${D}${bindir}/7z << 'EOF'
-#!/bin/sh
-exec "$(dirname "$0")"/7z.bin "$@"
-EOF
- chmod 0755 ${D}${bindir}/7z
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/bin/* ${D}${bindir}
+ ln -s 7za ${D}${bindir}/7z
}
BBCLASSEXTEND = "native"