aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gmock/gmock_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/gmock/gmock_1.7.0.bb')
-rw-r--r--meta-oe/recipes-test/gmock/gmock_1.7.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/gmock/gmock_1.7.0.bb b/meta-oe/recipes-test/gmock/gmock_1.7.0.bb
new file mode 100644
index 0000000000..bd5cf4e200
--- /dev/null
+++ b/meta-oe/recipes-test/gmock/gmock_1.7.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Google C++ Mocking Framework"
+SECTION = "libs"
+HOMEPAGE = "http://code.google.com/p/googlemock/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
+
+SRC_URI = "\
+ http://googlemock.googlecode.com/files/${BPN}-${PV}.zip \
+ file://cmake-Add-install-command-for-libraries-and-headers.patch \
+ file://cmake-gmock.pc.in-Add-pkg-config-support.patch \
+"
+
+SRC_URI[md5sum] = "073b984d8798ea1594f5e44d85b20d66"
+SRC_URI[sha256sum] = "26fcbb5925b74ad5fc8c26b0495dfc96353f4d553492eb97e85a8a6d2f43095b"
+
+inherit lib_package cmake
+
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dbg = "1"
+
+RDEPENDS_${PN}-dev += "${PN}-staticdev"
+
+BBCLASSEXTEND = "nativesdk"