aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch')
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch35
1 files changed, 13 insertions, 22 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch b/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
index 906ec99a9d..610113e6fe 100644
--- a/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
+++ b/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
@@ -10,45 +10,36 @@ Upstream-Status: Pending
src/utilities/Makefile.am | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
-diff --git a/src/Makefile.am b/src/Makefile.am
-index a26a197b..70a28174 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -14,7 +14,7 @@ AM_CPPFLAGS = \
- `pkg-config --silence-errors --cflags json` \
- `pkg-config --silence-errors --cflags json-c` \
- -pthread `pkg-config --cflags glib-2.0 gio-2.0` \
+@@ -13,7 +13,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/efi_runtime \
+ -I$(top_srcdir)/smccc_test \
+ -pthread \
- -Wall -Werror -Wextra \
+ -Wall -Wextra \
-Wno-address-of-packed-member \
-Wfloat-equal -Wmissing-declarations \
-Wno-long-long -Wredundant-decls -Wshadow \
-diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
-index 55c52b41..b85d0101 100644
--- a/src/lib/src/Makefile.am
+++ b/src/lib/src/Makefile.am
-@@ -25,7 +25,7 @@ AM_CPPFLAGS = \
- `pkg-config --silence-errors --cflags json-c` \
- `pkg-config --cflags glib-2.0 gio-2.0` \
+@@ -22,7 +22,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/acpica/source/include \
+ -I$(top_srcdir)/src/acpica/source/compiler \
-DDATAROOTDIR=\"$(datarootdir)\" \
- -Wall -Werror -Wextra \
-+ -Wall -Wextra \
++ -Wall -Wextra \
-Wno-address-of-packed-member
pkglib_LTLIBRARIES = libfwts.la
-diff --git a/src/utilities/Makefile.am b/src/utilities/Makefile.am
-index ecc25f0a..129c1036 100644
--- a/src/utilities/Makefile.am
+++ b/src/utilities/Makefile.am
@@ -16,7 +16,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
#
--AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
-+AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
- `pkg-config --silence-errors --cflags json` \
- `pkg-config --silence-errors --cflags json-c` \
- -I../lib/include
---
-2.25.1
-
+-AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
++AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
+ -I$(srcdir)/../lib/include
+
+ bin_PROGRAMS = kernelscan