aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/bats/bats_1.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/bats/bats_1.11.0.bb')
-rw-r--r--meta-oe/recipes-test/bats/bats_1.11.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.11.0.bb b/meta-oe/recipes-test/bats/bats_1.11.0.bb
new file mode 100644
index 0000000000..f0615f7b79
--- /dev/null
+++ b/meta-oe/recipes-test/bats/bats_1.11.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Bash Automated Testing System"
+DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
+provides a simple way to verify that the UNIX programs you write behave as expected."
+HOMEPAGE = "https://github.com/bats-core/bats-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
+
+SRC_URI = "\
+ git://github.com/bats-core/bats-core.git;branch=master;protocol=https \
+ "
+
+# v1.10.0
+SRCREV = "7531b575bb81487553553aecb654c41b237ae96c"
+
+S = "${WORKDIR}/git"
+
+# Numerous scripts assume ${baselib} == lib, which is not true.
+#
+do_configure:prepend() {
+ for f in ${S}/libexec/bats-core/* ${S}/lib/bats-core/* ; do
+ sed -i 's:\$BATS_ROOT/lib/:\$BATS_ROOT/${baselib}/:g' $f
+ done
+}
+
+do_install() {
+ # Just a bunch of bash scripts to install
+ ${S}/install.sh ${D}${prefix} ${baselib}
+}
+
+RDEPENDS:${PN} = "bash"
+FILES:${PN} += "${libdir}/bats-core/*"
+
+PACKAGECONFIG ??= "pretty"
+PACKAGECONFIG[pretty] = ",,,ncurses"