aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb')
-rw-r--r--meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb b/meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb
new file mode 100644
index 0000000000..44aeaed099
--- /dev/null
+++ b/meta-oe/recipes-support/uhubctl/uhubctl_2.4.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "USB hub per-port power control"
+HOMEPAGE = "https://github.com/mvp/uhubctl"
+BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
+DEPENDS = "libusb1"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCREV = "014b55ac5d1d7fb46a8f1eefe9fc3b87ea65a75f"
+SRC_URI = "git://github.com/mvp/${BPN}"
+S = "${WORKDIR}/git"
+
+# uhubctl gets its program version from "git describe". As we use the source
+# archive do reduce download size replace the call with our hardcoded version.
+do_configure:append() {
+ sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}