aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb')
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb b/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb
new file mode 100644
index 0000000000..c103c34936
--- /dev/null
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Very fast, header only, C++ logging library."
+HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "eb3220622e73a4889eee355ffa37972b3cac3df5"
+SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x; \
+ file://0001-Enable-use-of-external-fmt-library.patch"
+
+DEPENDS += "fmt"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+# no need to build example&text&benchmarks on pure yocto
+EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
+
+inherit cmake
+
+# Header-only library
+RDEPENDS:${PN}-dev = ""
+RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"