aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb')
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb b/meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb
new file mode 100644
index 0000000000..7d28fff5e3
--- /dev/null
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.8.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Very fast, header only, C++ logging library."
+HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "cbe9448650176797739dbab13961ef4c07f4290f"
+SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x;"
+
+DEPENDS += "fmt"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+# no need to build example&text&benchmarks on pure yocto
+EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
+
+inherit cmake
+
+# Header-only library
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"