aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/remmina/remmina_1.4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/remmina/remmina_1.4.18.bb')
-rw-r--r--meta-oe/recipes-support/remmina/remmina_1.4.18.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/remmina/remmina_1.4.18.bb b/meta-oe/recipes-support/remmina/remmina_1.4.18.bb
new file mode 100644
index 0000000000..954da272eb
--- /dev/null
+++ b/meta-oe/recipes-support/remmina/remmina_1.4.18.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+"
+HOMEPAGE = "https://remmina.org"
+SECTION = "Support"
+LICENSE = "GPLv2 & openssl"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
+
+DEPENDS = " \
+ glib-2.0-native \
+ openssl \
+ freerdp \
+ gtk+3 \
+ gdk-pixbuf \
+ atk \
+ libgcrypt \
+ libsodium \
+ libssh \
+ vte \
+ json-glib \
+ libsoup-2.4 \
+ libvncserver \
+ libsecret \
+ libxkbfile \
+"
+
+DEPENDS_append_libc-musl = " libexecinfo"
+LDFLAGS_append_libc-musl = " -lexecinfo"
+
+SRCREV = "045862cc7d7dd986b349c68131df2f86b9b1cd9c"
+SRC_URI = "git://gitlab.com/Remmina/Remmina;protocol=https"
+S = "${WORKDIR}/git"
+
+inherit cmake features_check mime mime-xdg gtk-icon-cache
+REQUIRED_DISTRO_FEATURES = "x11"
+
+EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF"
+
+PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol"
+# Switch on gtk support in avahi recipe if you want to enable avahi support
+PACKAGECONFIG[avahi] = "-DWITH_AVAHI=ON, -DWITH_AVAHI=OFF, avahi"
+
+RDEPENDS_${PN} = "bash"
+
+FILES_${PN}+= " \
+ ${datadir}/metainfo \
+ ${datadir}/mime \
+"