aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler/poppler
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler')
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch36
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch91
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch11
3 files changed, 36 insertions, 102 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch b/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch
new file mode 100644
index 0000000000..5b66a8a9c6
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch
@@ -0,0 +1,36 @@
+From b6fc6c36d359a50503138cd87d7147faf6dff893 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sat, 17 Mar 2018 20:52:10 +0100
+Subject: [PATCH] Do not overwrite all our build flags
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ cmake/modules/PopplerMacros.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/PopplerMacros.cmake b/cmake/modules/PopplerMacros.cmake
+index ccb2790..f29481e 100644
+--- a/cmake/modules/PopplerMacros.cmake
++++ b/cmake/modules/PopplerMacros.cmake
+@@ -98,6 +98,7 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
+ set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
+
++if(false)
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ # set the default compile warnings
+ set(_warn "-Wall -Wextra -Wpedantic")
+@@ -159,4 +160,5 @@ if(CMAKE_C_COMPILER MATCHES "icc")
+ set(CMAKE_C_FLAGS_DEBUG "-O2 -g -Ob0 -noalign ${_save_cflags}")
+ set(CMAKE_C_FLAGS_DEBUGFULL "-g -Ob0 -noalign ${_save_cflags}")
+ endif(CMAKE_C_COMPILER MATCHES "icc")
++endif(false)
+
+--
+2.14.3
+
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch b/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch
deleted file mode 100644
index 4e80d240fa..0000000000
--- a/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 91b6275f0e91c25beb040b4ef9484053ae305d86 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Tue, 26 May 2015 12:45:47 +0200
-Subject: [PATCH] add manadatory options to find qt4/qt5 moc
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Inappropriate [OE specific]
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- configure.ac | 55 ++++++++-----------------------------------------------
- 1 file changed, 8 insertions(+), 47 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index c4cfc2c..8e961c7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -712,25 +712,10 @@ AC_SUBST(POPPLER_QT4_LIBS)
- AC_SUBST(POPPLER_QT4_TEST_LIBS)
-
- if test x$enable_poppler_qt4 = xyes; then
-- AC_CHECK_TOOL(MOCQT4, moc)
-- AC_MSG_CHECKING([for Qt4 moc])
-- mocversion=`$MOCQT4 -v 2>&1`
-- mocversiongrep=`echo $mocversion | grep "Qt 4"`
-- if test x"$mocversiongrep" != x"$mocversion"; then
-- AC_MSG_RESULT([no])
-- # moc was not the qt4 one, try with moc-qt4
-- AC_CHECK_TOOL(MOCQT42, moc-qt4)
-- AC_MSG_CHECKING([for Qt4 moc-qt4])
-- mocversion=`$MOCQT42 -v 2>&1`
-- mocversiongrep=`echo $mocversion | grep "Qt 4"`
-- if test x"$mocversiongrep" != x"$mocversion"; then
-- # no valid moc found
-- enable_poppler_qt4=no;
-- MOCQT4="not found"
-- else
-- MOCQT4=$MOCQT42
-- fi
-- fi
-+ AC_ARG_WITH([moc-qt4],
-+ AS_HELP_STRING([--with-moc-qt4], [Set location of qt4 moc]),
-+ [MOCQT4=$withval]
-+ )
- AC_SUBST(MOCQT4)
- AC_MSG_RESULT([$MOCQT4])
- fi
-@@ -769,34 +754,10 @@ AC_SUBST(POPPLER_QT5_LIBS)
- AC_SUBST(POPPLER_QT5_TEST_LIBS)
-
- if test x$enable_poppler_qt5 = xyes; then
-- AC_CHECK_TOOL(MOCQT5, moc)
-- AC_MSG_CHECKING([for Qt5 moc])
-- mocversion=`$MOCQT5 -v 2>&1`
-- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
-- if test x"$mocversiongrep" != x"$mocversion"; then
-- AC_MSG_RESULT([no])
-- # moc was not the qt5 one, try with moc-qt5
-- AC_CHECK_TOOL(MOCQT52, moc-qt5)
-- AC_MSG_CHECKING([for Qt5 moc-qt5])
-- mocversion=`$MOCQT52 -v 2>&1`
-- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc-qt5 5|moc 5"`
-- if test x"$mocversiongrep" != x"$mocversion"; then
-- AC_CHECK_TOOL(QTCHOOSER, qtchooser)
-- AC_MSG_CHECKING([for qtchooser])
-- qt5tooldir=`QT_SELECT=qt5 qtchooser -print-env | grep QTTOOLDIR | cut -d '=' -f 2 | cut -d \" -f 2`
-- mocversion=`$qt5tooldir/moc -v 2>&1`
-- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
-- if test x"$mocversiongrep" != x"$mocversion"; then
-- # no valid moc found
-- enable_poppler_qt5=no;
-- MOCQT5="not found"
-- else
-- MOCQT5=$qt5tooldir/moc
-- fi
-- else
-- MOCQT5=$MOCQT52
-- fi
-- fi
-+ AC_ARG_WITH([moc-qt5],
-+ AS_HELP_STRING([--with-moc-qt5], [Set location of qt5 moc]),
-+ [MOCQT5=$withval]
-+ )
- AC_SUBST(MOCQT5)
- AC_MSG_RESULT([$MOCQT5])
- fi
---
-2.5.5
-
diff --git a/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch b/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch
deleted file mode 100644
index 406009f4fa..0000000000
--- a/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- poppler-0.45.0/poppler/CairoOutputDev.cc.orig 2016-06-17 14:23:35.399083929 -0400
-+++ poppler-0.45.0/poppler/CairoOutputDev.cc 2016-06-17 14:36:53.351097825 -0400
-@@ -42,7 +42,7 @@
- #endif
-
- #include <string.h>
--#include <math.h>
-+#include <cmath>
- #include <assert.h>
- #include <cairo.h>
-