aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch')
-rw-r--r--meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch b/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch
new file mode 100644
index 0000000000..f67e1f5039
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch
@@ -0,0 +1,28 @@
+Configuration changes needed to allow building with QT4-embedded
+
+Index: poppler-0.35.0/configure.ac
+===================================================================
+--- poppler-0.35.0.orig/configure.ac
++++ poppler-0.35.0/configure.ac
+@@ -654,17 +654,17 @@ AC_ARG_ENABLE(poppler-qt4,
+ enable_poppler_qt4="try")
+ if test x$enable_poppler_qt4 = xyes; then
+ PKG_CHECK_MODULES(POPPLER_QT4,
+- QtCore >= 4.7.0 QtGui >= 4.7.0 QtXml >= 4.7.0)
++ QtCoreE >= 4.7.0 QtGuiE >= 4.7.0 QtXmlE >= 4.7.0)
+ PKG_CHECK_MODULES(POPPLER_QT4_TEST,
+- QtTest >= 4.7.0)
++ QtTestE >= 4.7.0)
+ elif test x$enable_poppler_qt4 = xtry; then
+ PKG_CHECK_MODULES(POPPLER_QT4,
+- QtCore >= 4.7.0 QtGui >= 4.7.0 QtXml >= 4.7.0,
++ QtCoreE >= 4.7.0 QtGuiE >= 4.7.0 QtXmlE >= 4.7.0,
+ [enable_poppler_qt4="yes"],
+ [enable_poppler_qt4="no"])
+ if test x$enable_poppler_qt4 = xyes; then
+ PKG_CHECK_MODULES(POPPLER_QT4_TEST,
+- QtTest >= 4.7.0,
++ QtTestE >= 4.7.0,
+ [enable_poppler_qt4="yes"],
+ [enable_poppler_qt4="no"])
+ fi