aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openct
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/openct')
-rw-r--r--meta-oe/recipes-support/openct/openct_0.6.20.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/openct/openct_0.6.20.bb b/meta-oe/recipes-support/openct/openct_0.6.20.bb
index 4a1a0f568d..2077335670 100644
--- a/meta-oe/recipes-support/openct/openct_0.6.20.bb
+++ b/meta-oe/recipes-support/openct/openct_0.6.20.bb
@@ -62,7 +62,7 @@ do_install () {
install -d ${D}${sysconfdir}
# fix up hardcoded paths
sed -i -e 's,/etc/,${sysconfdir}/,' -e 's,/usr/sbin/,${sbindir}/,' \
- ${WORKDIR}/openct.service ${WORKDIR}/openct.init
+ ${UNPACKDIR}/openct.service ${UNPACKDIR}/openct.init
oe_runmake install DESTDIR=${D}
install -dm 755 ${D}${libdir}/ctapi/
@@ -70,11 +70,11 @@ do_install () {
install -Dpm 644 etc/openct.udev ${D}${nonarch_libdir}/udev/rules.d/60-openct.rules
install -pm 644 etc/openct.conf ${D}${sysconfdir}/openct.conf
- install -Dpm 755 ${WORKDIR}/openct.init ${D}${sysconfdir}/init.d/openct
- install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}${sysconfdir}/sysconfig/openct
+ install -Dpm 755 ${UNPACKDIR}/openct.init ${D}${sysconfdir}/init.d/openct
+ install -Dpm 644 ${UNPACKDIR}/openct.sysconfig ${D}${sysconfdir}/sysconfig/openct
install -d ${D}${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/openct.service ${D}${systemd_unitdir}/system
+ install -m 644 ${UNPACKDIR}/openct.service ${D}${systemd_unitdir}/system
so=$(find ${D} -name \*.so | sed "s|^${D}||")
sed -i -e 's|\\(LIBPATH\\s*\\).*|\\1$so|' etc/reader.conf
@@ -82,3 +82,8 @@ do_install () {
}
BBCLASSEXTEND = "native"
+
+# http://errors.yoctoproject.org/Errors/Details/766890/
+# openct-0.6.20/src/ifd/ifdhandler.c:239:52: error: passing argument 2 of 'ifd_get_eventfd' from incompatible pointer type [-Wincompatible-pointer-types]
+# openct-0.6.20/src/ifd/process.c:461:61: error: passing argument 4 of 'ct_tlv_get_opaque' from incompatible pointer type [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"