aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mcelog')
-rw-r--r--meta-oe/recipes-support/mcelog/mce-inject_git.bb8
-rw-r--r--meta-oe/recipes-support/mcelog/mce-test_git.bb16
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog/0001-client-Include-string.h-form-mem-function-prototypes.patch26
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch36
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog/run-ptest8
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_200.bb (renamed from meta-oe/recipes-support/mcelog/mcelog_175.bb)29
6 files changed, 64 insertions, 59 deletions
diff --git a/meta-oe/recipes-support/mcelog/mce-inject_git.bb b/meta-oe/recipes-support/mcelog/mce-inject_git.bb
index cc33cbaf28..08ec8c574e 100644
--- a/meta-oe/recipes-support/mcelog/mce-inject_git.bb
+++ b/meta-oe/recipes-support/mcelog/mce-inject_git.bb
@@ -4,15 +4,15 @@ software level into a running Linux kernel. This is intended for \
validation of the kernel machine check handler."
SECTION = "System Environment/Base"
-SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-inject.git"
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-inject.git;branch=master"
-SRCREV = "4cbe46321b4a81365ff3aafafe63967264dbfec5"
+SRCREV = "7668d820cadce2da9d90b72aab14c3e637ca47d6"
UPSTREAM_CHECK_COMMITS = "1"
DEPENDS = "bison-native"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://README;beginline=30;md5=94c18755082a2da9c9cf97cba3ad47d6"
S = "${WORKDIR}/git"
@@ -21,4 +21,4 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
inherit autotools-brokensep
-EXTRA_OEMAKE = "destdir=${D}"
+EXTRA_OEMAKE = "destdir=${D} CFLAGS='${CFLAGS}'"
diff --git a/meta-oe/recipes-support/mcelog/mce-test_git.bb b/meta-oe/recipes-support/mcelog/mce-test_git.bb
index 35fb944702..0a6fd684eb 100644
--- a/meta-oe/recipes-support/mcelog/mce-test_git.bb
+++ b/meta-oe/recipes-support/mcelog/mce-test_git.bb
@@ -7,25 +7,27 @@ DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for
testing the Linux RAS related features, including CPU/Memory error \
containment and recovery, ACPI/APEI support etc."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git;branch=master \
file://makefile-remove-ldflags.patch \
file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \
"
-SRCREV = "7643baf6c3919b3d727e6ba6c2e545dc6a653307"
-PV = "20190917+git${SRCPV}"
+SRCREV = "9d11fc3e05eae7b454efeb5941beded56f80445b"
+PV = "20230601+git"
-RDEPENDS_${PN} = "mcelog mce-inject dialog bash"
+RDEPENDS:${PN} = "mcelog mce-inject dialog bash"
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
S ="${WORKDIR}/git"
-do_install_append(){
+EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
+
+do_install:append(){
install -d ${D}/opt/mce-test
cp -rf ${S}/* ${D}/opt/mce-test/
}
-FILES_${PN} += "/opt"
+FILES:${PN} += "/opt"
diff --git a/meta-oe/recipes-support/mcelog/mcelog/0001-client-Include-string.h-form-mem-function-prototypes.patch b/meta-oe/recipes-support/mcelog/mcelog/0001-client-Include-string.h-form-mem-function-prototypes.patch
new file mode 100644
index 0000000000..3b6fd7d702
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog/0001-client-Include-string.h-form-mem-function-prototypes.patch
@@ -0,0 +1,26 @@
+From c7753f82261d49862d5e0f9691bf87799d36ef0c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 31 Aug 2022 16:20:03 -0700
+Subject: [PATCH] client: Include string.h form mem* function prototypes
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ client.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/client.c b/client.c
+index 883b1de..e474e55 100644
+--- a/client.c
++++ b/client.c
+@@ -16,6 +16,7 @@
+ on your Linux system; if not, write to the Free Software Foundation,
+ Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA */
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <unistd.h>
+--
+2.37.3
+
diff --git a/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch b/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch
deleted file mode 100644
index 03bcc451df..0000000000
--- a/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 3765b3a4cabf76f55c1c126ac64780a8c117d1d9 Mon Sep 17 00:00:00 2001
-From: Mingli Yu <mingli.yu@windriver.com>
-Date: Tue, 12 Jan 2021 10:30:13 +0800
-Subject: [PATCH] test: avoid the pfa test hang
-
-Per [1], the pfa test needs to install page-types and the pfa test
-will hang forever if there is no page-types installed.
-
-Improve the test script to avoid the pfa test hang.
-
-[1] https://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git/tree/tests/pfa/PFA_test_howto?id=7b776a8c005b60572f49797e81287540f99fff1f
-
-Upstream-Status: Submitted [https://github.com/andikleen/mcelog/pull/87]
-
-Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
----
- tests/test | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/test b/tests/test
-index 020ae2b..320f57f 100755
---- a/tests/test
-+++ b/tests/test
-@@ -47,6 +47,9 @@ do
- # Inject mce records and run mcelog in parallel.
- # So that the mce records can be consumed by mcelog in time (avoid mce record overflow).
- ./inject $conf &
-+ if [ "$1" = "pfa" ] ; then
-+ which page-types > /dev/null 2>&1 || continue
-+ fi
- $D ../../mcelog --foreground --daemon --debug-numerrors --config $conf --logfile $log >> result
-
- # let triggers finish
---
-2.29.2
-
diff --git a/meta-oe/recipes-support/mcelog/mcelog/run-ptest b/meta-oe/recipes-support/mcelog/mcelog/run-ptest
index ba7a2c7683..320240f276 100644
--- a/meta-oe/recipes-support/mcelog/mcelog/run-ptest
+++ b/meta-oe/recipes-support/mcelog/mcelog/run-ptest
@@ -1,3 +1,9 @@
#!/bin/sh
-make -C tests test
+make -C tests test | sed -e '/\[PASS\]/ s/^/PASS: /g' \
+ -e '/\[FAIL\]/ s/^/FAIL: /g' \
+ -e '/\[IGNORE\]/ s/^/SKIP: /g' \
+ -e 's/IGNORE:/SKIP:/' \
+ -e 's/: \[PASS\]//' \
+ -e 's/: \[FAIL\]//' \
+ -e 's/: \[IGNORE\]//'
diff --git a/meta-oe/recipes-support/mcelog/mcelog_175.bb b/meta-oe/recipes-support/mcelog/mcelog_200.bb
index ae810eff8e..9d72e78599 100644
--- a/meta-oe/recipes-support/mcelog/mcelog_175.bb
+++ b/meta-oe/recipes-support/mcelog/mcelog_200.bb
@@ -2,26 +2,33 @@ SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
and should run on all Linux systems that need error handling."
-HOMEPAGE = "http://mcelog.org/"
+HOMEPAGE = "https://mcelog.org/"
SECTION = "System Environment/Base"
-SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
- file://0001-test-avoid-the-pfa-test-hang.patch \
- file://run-ptest \
-"
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \
+ file://0001-client-Include-string.h-form-mem-function-prototypes.patch \
+ file://run-ptest \
+ "
-SRCREV = "7b776a8c005b60572f49797e81287540f99fff1f"
+SRCREV = "955fd0917ab1b9f159443e5cbba1d0fa73486fac"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
S = "${WORKDIR}/git"
-inherit autotools-brokensep ptest
+inherit ptest
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
-do_install_append() {
+EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
install -d ${D}${sysconfdir}/cron.hourly
install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
@@ -33,4 +40,4 @@ do_install_ptest() {
sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
}
-RDEPENDS_${PN}-ptest += "make bash mce-inject"
+RDEPENDS:${PN}-ptest += "make bash mce-inject"