aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_1.09.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_1.09.bb32
1 files changed, 21 insertions, 11 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.09.bb b/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
index 34ff643a56..542b2ba19a 100644
--- a/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
+++ b/meta-oe/recipes-support/mcelog/mcelog_1.09.bb
@@ -4,23 +4,33 @@ and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks
and should run on all Linux systems that need error handling."
HOMEPAGE = "http://mcelog.org/"
SECTION = "System Environment/Base"
-DEPENDS += "bash"
-SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git \
+ file://mcelog-debash.patch \
+ file://run-ptest \
+"
+
SRCREV = "0fc9f702232cb2d9969916f899c67c3e64deedda"
+
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://README;md5=3eb76ca64fa07ad53ebb0ebb5b4c8ede"
S = "${WORKDIR}/git"
-do_install() {
- install -d ${D}/${sbindir}
- install -m 0755 ${S}/mcelog ${D}/${sbindir}
- install -d ${D}/${mandir}/man8
- install -m 0644 ${S}/mcelog.8 ${D}/${mandir}/man8/
- install -d ${D}/etc/cron.hourly
- install -m 0755 ${S}/mcelog.cron ${D}/etc/cron.hourly/
-}
+inherit autotools-brokensep ptest
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
-RDEPENDS_${PN} = "bash"
+do_install_append() {
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
+ sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
+ sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
+}
+
+RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"