aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mce-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mce-test_git.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mce-test_git.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/mcelog/mce-test_git.bb b/meta-oe/recipes-support/mcelog/mce-test_git.bb
index 35fb944702..05e98e86ed 100644
--- a/meta-oe/recipes-support/mcelog/mce-test_git.bb
+++ b/meta-oe/recipes-support/mcelog/mce-test_git.bb
@@ -7,25 +7,27 @@ DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for
testing the Linux RAS related features, including CPU/Memory error \
containment and recovery, ACPI/APEI support etc."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git;branch=master \
file://makefile-remove-ldflags.patch \
file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \
"
-SRCREV = "7643baf6c3919b3d727e6ba6c2e545dc6a653307"
-PV = "20190917+git${SRCPV}"
+SRCREV = "025014dedca39d2b8a57a82e52286e72e157d73a"
+PV = "20222810+git"
-RDEPENDS_${PN} = "mcelog mce-inject dialog bash"
+RDEPENDS:${PN} = "mcelog mce-inject dialog bash"
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
S ="${WORKDIR}/git"
-do_install_append(){
+EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
+
+do_install:append(){
install -d ${D}/opt/mce-test
cp -rf ${S}/* ${D}/opt/mce-test/
}
-FILES_${PN} += "/opt"
+FILES:${PN} += "/opt"