aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing/liburing_2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/liburing/liburing_2.2.bb')
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing_2.2.bb b/meta-oe/recipes-support/liburing/liburing_2.2.bb
new file mode 100644
index 0000000000..8cc7d74f9f
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing_2.2.bb
@@ -0,0 +1,29 @@
+SUMMARY = "This is the io_uring library, liburing."
+DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
+instances, and also a simplified interface for applications that don't need \
+(or want) to deal with the full kernel side implementation."
+HOMEPAGE = "https://github.com/axboe/liburing"
+BUGTRACKER = "https://github.com/axboe/liburing/issues"
+SECTION = "libs"
+
+LICENSE = "LGPL-2.1-only | MIT"
+LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
+
+SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
+SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
+SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
+SRCREV = "dda4848a9911120a903bef6284fb88286f4464c9"
+
+S = "${WORKDIR}/git"
+
+DEPENDS:append:libc-musl = " libucontext"
+XCFLAGS = "-pthread"
+XCFLAGS:append:libc-musl = " -lucontext"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
+do_configure() {
+ ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
+}
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}