aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libtinyxml2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libtinyxml2')
-rw-r--r--meta-oe/recipes-support/libtinyxml2/files/run-ptest10
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb30
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_8.1.0.bb17
3 files changed, 40 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/files/run-ptest b/meta-oe/recipes-support/libtinyxml2/files/run-ptest
new file mode 100644
index 0000000000..870912672e
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/files/run-ptest
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+for i in `ls xmltest`; do
+ ./$i
+ if [ $? -eq 0 ]; then
+ echo "PASS: $i"
+ else
+ echo "FAIL: $i"
+ fi
+done
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb
new file mode 100644
index 0000000000..bcd309282b
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs"
+HOMEPAGE = "https://leethomason.github.io/tinyxml2"
+SECTION = "libs"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
+
+SRCREV = "321ea883b7190d4e85cae5512a12e5eaa8f8731f"
+SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
+ file://run-ptest"
+
+S = "${WORKDIR}/git"
+
+inherit meson ptest
+
+EXTRA_OEMESON += " \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)} \
+ -Ddefault_library=both \
+"
+
+CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
+
+do_install_ptest() {
+ install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
+ install -d ${D}${PTEST_PATH}/resources/out
+ for f in ${S}/resources/*.xml; do
+ install -m 0644 $f ${D}${PTEST_PATH}/resources/
+ done
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_8.1.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_8.1.0.bb
deleted file mode 100644
index 5245059a89..0000000000
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_8.1.0.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs"
-HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/"
-SECTION = "libs"
-LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
-
-SRC_URI = "git://github.com/leethomason/tinyxml2.git"
-
-SRCREV = "3291390336141573e51dfa991b4179c8bcd8f306"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-BBCLASSEXTEND = "native"
-
-EXTRA_OECMAKE += "-Dtinyxml2_SHARED_LIBS=YES"