aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch')
-rw-r--r--meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch b/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
new file mode 100644
index 0000000000..ee217441b6
--- /dev/null
+++ b/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
@@ -0,0 +1,20 @@
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,15 @@ CLEANFILES = \
+ route/pktloc_grammar.c route/pktloc_grammar.h \
+ route/pktloc_syntax.c route/pktloc_syntax.h
+
++BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+