aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb')
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb b/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
new file mode 100644
index 0000000000..118259e4fd
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "c9864f4dd03736839f40d225da494cb1eb64e654"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre2 \
+ gmp \
+ mpfr \
+ gettext-native \
+"
+
+FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
+
+EXTRA_OECONF = "--without-gtk-doc"
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"