aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb')
-rw-r--r--meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb b/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
new file mode 100644
index 0000000000..9e7d2fcd8c
--- /dev/null
+++ b/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ATA S.M.A.R.T. Reading and Parsing Library"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "udev"
+
+SRCREV = "de6258940960443038b4c1651dfda3620075e870"
+SRC_URI = "git://git.0pointer.de/libatasmart.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools lib_package
+
+do_install_append() {
+ sed -i -e s://:/:g -e 's:=${libdir}/libudev.la:-ludev:g' ${D}${libdir}/libatasmart.la
+}
+
+PACKAGES =+ "${PN}-dev-vala"
+FILES_${PN}-dev-vala = "${datadir}/vala"