aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb')
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
new file mode 100644
index 0000000000..e261eb8b70
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
@@ -0,0 +1,43 @@
+SUMMARY = "ImageMagick is an image convertion tools"
+SECTION = "console/utils"
+LICENSE = "ImageMagick"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d84c6ddd4028aa53d028b4c50f9361e"
+# FIXME: There is much more checked libraries. All should be added or explicitly disabled to get consistent results.
+DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
+
+PATCHSET = "10"
+SRC_URI = "http://www.imagemagick.org/download/legacy/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
+ file://remove.dist-lzip.patch \
+"
+SRC_URI[md5sum] = "a3a0fa301965d6fde68fccd066f62b0b"
+SRC_URI[sha256sum] = "8c0982b2bc0c1cea8ac9627b4e1e5d37f8171ef8282ee09aef32529cf68e1820"
+
+S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
+
+inherit autotools binconfig pkgconfig
+
+# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
+# if someone needs xml support then fix it first
+EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-x --without-perl --disable-openmp --without-xml --disable-opencl"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[jp2] = "--with-jp2,--without-jp2,jasper"
+
+FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
+ ${libdir}/ImageMagick-${PV}/config-Q16 \
+ ${datadir}/ImageMagick-6 "
+
+FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
+
+FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
+
+BBCLASSEXTEND = "native"
+
+LEAD_SONAME = "libMagickCore.so.*"
+
+do_configure_prepend() {
+ export ac_cv_sys_file_offset_bits=yes
+}