aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.1.0.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb
new file mode 100644
index 0000000000..3d4a23d65f
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
+DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
+complete with lines, arcs, text, multiple colors, cut and paste from other \
+images, and flood fills, and to write out the result as a PNG or JPEG file. \
+This is particularly useful in Web applications, where PNG and JPEG are two \
+of the formats accepted for inline images by most browsers. Note that gd is not \
+a paint program."
+HOMEPAGE = "http://libgd.bitbucket.org/"
+
+SECTION = "libs"
+LICENSE = "GD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
+DEPENDS = "freetype libpng jpeg zlib"
+
+SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2"
+SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b"
+SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91"
+
+S = "${WORKDIR}/libgd-${PV}"
+
+inherit autotools binconfig gettext
+
+EXTRA_OECONF += " --disable-rpath \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --with-freetype=${STAGING_LIBDIR}/.. \
+ --without-fontconfig \
+ --without-xpm \
+ --without-x"
+
+EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'