aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/freerdp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/freerdp')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp.inc24
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp_git.bb15
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc
new file mode 100644
index 0000000000..f8402c71d3
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp.inc
@@ -0,0 +1,24 @@
+# Copyright (C) 2010, 2011 O.S. Systems Software Ltda. All Rights Reserved
+# Released under the MIT license
+
+DESCRIPTION = "FreeRDP RDP client"
+HOMEPAGE = "http://freerdp.sourceforge.net"
+DEPENDS = "virtual/libx11 openssl libxcursor cups alsa-lib"
+SECTION = "x11/network"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+INC_PR = "r0"
+
+inherit pkgconfig autotools
+
+do_configure_prepend() {
+ # workaround gcc linking bug
+ find ${S} -name 'Makefile.am' | xargs -n 1 sed 's,-pthread,-lpthread -D_REENTRANT,g' -i
+}
+
+do_install_append() {
+ rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la
+}
+
+RDEPENDS_${PN} += "xprop"
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb
new file mode 100644
index 0000000000..fa4ba9ae29
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2010, 2011, O.S. Systems Software Ltda.
+# Released under the MIT license
+
+include freerdp.inc
+
+inherit gitpkgv
+
+PV = "gitr${SRCPV}"
+PKGV = "${GITPKGVTAG}"
+PR = "${INC_PR}.0"
+
+SRCREV = "7bbde4fb3bc3a781364d0a626c49bc165cc507fd"
+SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;protocol=git"
+
+S = "${WORKDIR}/git"