aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fmt/fmt_6.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fmt/fmt_6.0.0.bb')
-rw-r--r--meta-oe/recipes-support/fmt/fmt_6.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fmt/fmt_6.0.0.bb b/meta-oe/recipes-support/fmt/fmt_6.0.0.bb
new file mode 100644
index 0000000000..c35c77b125
--- /dev/null
+++ b/meta-oe/recipes-support/fmt/fmt_6.0.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "open-source formatting library for C++"
+DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
+HOMEPAGE = "https://fmt.dev"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b"
+
+SRC_URI += "git://github.com/fmtlib/fmt"
+SRCREV = "7512a55aa3ae309587ca89668ef9ec4074a51a1f"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"