aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fmt/fmt_10.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fmt/fmt_10.2.1.bb')
-rw-r--r--meta-oe/recipes-support/fmt/fmt_10.2.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fmt/fmt_10.2.1.bb b/meta-oe/recipes-support/fmt/fmt_10.2.1.bb
new file mode 100644
index 0000000000..1437eb4803
--- /dev/null
+++ b/meta-oe/recipes-support/fmt/fmt_10.2.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "open-source formatting library for C++"
+DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
+HOMEPAGE = "https://fmt.dev"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b9257785fc4f3803a4b71b76c1412729"
+
+SRC_URI = "git://github.com/fmtlib/fmt;branch=10.x;protocol=https"
+SRCREV = "e69e5f977d458f2650bb346dadf2ad30c5320281"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
+
+BBCLASSEXTEND = "native nativesdk"