aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/eject/eject_2.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/eject/eject_2.1.5.bb')
-rw-r--r--meta-oe/recipes-support/eject/eject_2.1.5.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/eject/eject_2.1.5.bb b/meta-oe/recipes-support/eject/eject_2.1.5.bb
index c47c653444..95345776bb 100644
--- a/meta-oe/recipes-support/eject/eject_2.1.5.bb
+++ b/meta-oe/recipes-support/eject/eject_2.1.5.bb
@@ -16,6 +16,14 @@ S = "${WORKDIR}/${BPN}"
PR = "r1"
+do_compile_prepend() {
+ # PO subdir must be in build directory
+ if [ ! ${S} = ${B} ]; then
+ mkdir -p ${B}/po
+ cp -r ${S}/po/* ${B}/po/
+ fi
+}
+
ALTERNATIVE_${PN} = "volname eject"
ALTERNATIVE_LINK_NAME[volname] = "${bindir}/volname"
ALTERNATIVE_LINK_NAME[eject] = "${bindir}/eject"