aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/driverctl/driverctl_0.111.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/driverctl/driverctl_0.111.bb')
-rw-r--r--meta-oe/recipes-support/driverctl/driverctl_0.111.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/driverctl/driverctl_0.111.bb b/meta-oe/recipes-support/driverctl/driverctl_0.111.bb
new file mode 100644
index 0000000000..7404f40c21
--- /dev/null
+++ b/meta-oe/recipes-support/driverctl/driverctl_0.111.bb
@@ -0,0 +1,28 @@
+SUMMARY = "driverctl is a device driver control utility for Linux"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1-only;md5=1a6d268fd218675ffea8be556788b780"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+DEPENDS = "systemd"
+RDEPENDS:${PN} += "bash bash-completion"
+
+SRC_URI = " git://gitlab.com/driverctl/driverctl.git"
+SRCREV = "fa9dce43d1a667d6e6e26895fbed01b3b04362c9"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig systemd features_check
+
+FILES:${PN} += "${libdir}"
+FILES:${PN} += "${libdir}/udev"
+FILES:${PN} += "${libdir}/udev/rules.d"
+FILES:${PN} += "${systemd_unitdir}"
+FILES:${PN} += "${systemd_unitdir}/system"
+FILES:${PN} += "${datadir}"
+FILES:${PN} += "${datadir}/bash-completion"
+FILES:${PN} += "${datadir}/bash-completion/completions"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}