aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
new file mode 100644
index 0000000000..4641b0181a
--- /dev/null
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
@@ -0,0 +1,24 @@
+require dfu-util_${PV}.bb
+
+inherit deploy native
+
+DEPENDS = "libusb1-native"
+
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
+
+do_deploy() {
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
+ rm -f ${DEPLOYDIR}/dfu-util
+ ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
+}
+
+addtask deploy before do_package after do_install
+
+# cleandirs should possibly be in deploy.bbclass but we need it
+do_deploy[cleandirs] = "${DEPLOYDIR}"
+# clear stamp-extra-info since MACHINE_ARCH is normally put there by
+# deploy.bbclass
+do_deploy[stamp-extra-info] = ""
+