aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/colord/colord.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/colord/colord.bb')
-rw-r--r--meta-oe/recipes-support/colord/colord.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/colord/colord.bb b/meta-oe/recipes-support/colord/colord.bb
index f514c0b782..e300222518 100644
--- a/meta-oe/recipes-support/colord/colord.bb
+++ b/meta-oe/recipes-support/colord/colord.bb
@@ -1,10 +1,10 @@
require ${BPN}.inc
-inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
+inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd pkgconfig
# polkit and gobject-introspection are mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+GIR_MESON_OPTION = ""
DEPENDS += " \
${BPN}-native \
@@ -28,9 +28,9 @@ EXTRA_OEMESON = " \
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
-SYSTEMD_SERVICE_${PN} = "colord.service"
+SYSTEMD_SERVICE:${PN} = "colord.service"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/dbus-1 \
${datadir}/polkit-1 \
${datadir}/glib-2.0 \
@@ -42,4 +42,4 @@ FILES_${PN} += " \
"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"
+USERADD_PARAM:${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"