aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/cli11/cli11_1.8.0.bb')
-rw-r--r--meta-oe/recipes-support/cli11/cli11_1.8.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cli11/cli11_1.8.0.bb b/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
new file mode 100644
index 0000000000..b6a4341595
--- /dev/null
+++ b/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "C++11 command line parser"
+DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
+SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \
+ file://0001-Add-CLANG_TIDY-check.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
+DEPENDS += "boost"