aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb')
-rw-r--r--meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb b/meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb
new file mode 100644
index 0000000000..ad94009b71
--- /dev/null
+++ b/meta-oe/recipes-support/bdwgc/bdwgc_8.2.0.bb
@@ -0,0 +1,39 @@
+SUMMARY = "A garbage collector for C and C++"
+
+DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
+ used as a garbage collecting replacement for C malloc or C++ new. It allows\
+ you to allocate memory basically as you normally would, without explicitly\
+ deallocating memory that is no longer useful. The collector automatically\
+ recycles memory when it determines that it can no longer be otherwise\
+ accessed.\
+ The collector is also used by a number of programming language\
+ implementations that either use C as intermediate code, want to facilitate\
+ easier interoperation with C libraries, or just prefer the simple collector\
+ interface.\
+ Alternatively, the garbage collector may be used as a leak detector for C\
+ or C++ programs, though that is not its primary goal.\
+ Empirically, this collector works with most unmodified C programs, simply\
+ by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
+ calls, and removing free calls."
+
+HOMEPAGE = "http://www.hboehm.info/gc/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.QUICK;md5=7912d9213b3547f8a81aadd08893fe84"
+
+DEPENDS = "libatomic-ops"
+
+SRCREV = "47e9106c17b72e9ee5501308f69ea94531e798b3"
+SRC_URI = "git://github.com/ivmai/bdwgc.git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-cpluscplus"
+
+CFLAGS:append:libc-musl = " -D_GNU_SOURCE -DNO_GETCONTEXT -DSEARCH_FOR_DATA_START -DUSE_MMAP -DHAVE_DL_ITERATE_PHDR"
+
+FILES:${PN}-doc = "${datadir}"
+
+BBCLASSEXTEND = "native nativesdk"