aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/navit
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-navigation/navit')
-rw-r--r--meta-oe/recipes-navigation/navit/navit-fpu.inc6
-rw-r--r--meta-oe/recipes-navigation/navit/navit.inc95
-rw-r--r--meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch16
-rw-r--r--meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch28
-rw-r--r--meta-oe/recipes-navigation/navit/navit/maps.xml24
-rw-r--r--meta-oe/recipes-navigation/navit/navit/navit.xml45
-rw-r--r--meta-oe/recipes-navigation/navit/navit/osd.xml15
-rw-r--r--meta-oe/recipes-navigation/navit/navit/plugins.xml6
-rw-r--r--meta-oe/recipes-navigation/navit/navit/speech.xml8
-rw-r--r--meta-oe/recipes-navigation/navit/navit_svn.bb11
10 files changed, 0 insertions, 254 deletions
diff --git a/meta-oe/recipes-navigation/navit/navit-fpu.inc b/meta-oe/recipes-navigation/navit/navit-fpu.inc
deleted file mode 100644
index 54b7a97793..0000000000
--- a/meta-oe/recipes-navigation/navit/navit-fpu.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-
-def get_navit_fpu_setting(bb, d):
- if d.getVar('TARGET_FPU') in [ 'soft' ]:
- return "--enable-avoid-float"
- return ""
-
diff --git a/meta-oe/recipes-navigation/navit/navit.inc b/meta-oe/recipes-navigation/navit/navit.inc
deleted file mode 100644
index 1c0bfdaae0..0000000000
--- a/meta-oe/recipes-navigation/navit/navit.inc
+++ /dev/null
@@ -1,95 +0,0 @@
-DESCRIPTION = "Navit is a car navigation system with routing engine."
-LICENSE = "GPLv2 & LGPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ed539d099d6ce08de6ea0dfed9ecb333 \
- file://LGPL-2;md5=3214f080875748938ba060314b4f727d \
- file://GPL-2;md5=751419260aa954499f7abaabaa882bbe \
-"
-
-SECTION = "x11/applications"
-DEPENDS = "glib-2.0 gd gypsy librsvg-native"
-RDEPENDS_${PN} = " ${PN}-icons ${PN}-config "
-RRECOMMENDS_${PN} = "gpsd ${PN}-dbus ${PN}-speech-cmdline ${PN}-gui-internal ${PN}-graphics-gtk"
-RSUGGESTS_${PN} = "flite-alsa espeak ${PN}-speech-dbus ${PN}-gui-gtk ${PN}-gui-qml ${PN}-graphics-sdl ${PN}-graphics-qt ${PN}-maptool"
-
-PE = "1"
-INC_PR = "r11"
-
-# Depends on gypsy
-PNBLACKLIST[navit] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
-
-inherit autotools gettext pkgconfig
-
-PACKAGECONFIG ?= ""
-PACKAGECONFIG[fribidi] = "--enable-fribidi,--disable-fribidi,fribidi"
-PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
-PACKAGECONFIG[sdl] = "--enable-graphics-sdl,--disable-graphics-sdl,libsdl"
-PACKAGECONFIG[gtk] = "--enable-graphics-gtk-drawing-area --enable-gui-gtk,--disable-graphics-gtk-drawing-area --disable-gui-gtk,gtk+"
-PACKAGECONFIG[qt] = "--enable-graphics-qt-qpainter --enable-gui-qml,--disable-graphics-qt-qpainter --disable-gui-qml,qt4-x11-free,qt4-plugin-imageformat-svg"
-
-EXTRA_OECONF += " \
- --disable-binding-python \
- --disable-samplemap \
- --enable-avoid-unaligned \
- --enable-svg2png-scaling-flag=32 \
- --disable-speech-speech-dispatcher \
- --enable-cache-size=20971520 \
-"
-
-# --enable-avoid-float \
-#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
-require navit-fpu.inc
-EXTRA_OECONF += "${@get_navit_fpu_setting(bb, d)}"
-
-PACKAGES =+ "${PN}-maptool ${PN}-config ${PN}-dbus ${PN}-speech-cmdline ${PN}-speech-dbus ${PN}-gui-gtk ${PN}-gui-internal ${PN}-gui-qml ${PN}-graphics-sdl ${PN}-graphics-gtk ${PN}-graphics-qt ${PN}-icons"
-
-EXTRA_AUTORECONF = " -I m4"
-
-CONFFILES_${PN}-config += "${datadir}/navit/navit.default.xml \
- ${datadir}/navit/navit.xml \
- ${datadir}/navit/maps.xml \
- ${datadir}/navit/osd.xml \
- ${datadir}/navit/speech.xml \
- ${datadir}/navit/plugins.xml \
-"
-
-SRC_URI += "file://navit.xml \
- file://maps.xml \
- file://osd.xml \
- file://speech.xml \
- file://plugins.xml \
-"
-
-FILES_${PN} += "${libdir}/${BPN}/*/*.so ${datadir}/icons"
-FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"
-FILES_${PN}-maptool = " ${bindir}/maptool "
-FILES_${PN}-config = " ${datadir}/navit/*.xml "
-FILES_${PN}-dbus = " ${datadir}/dbus-1/services/ ${libdir}/${BPN}/binding/libbinding_dbus.so "
-FILES_${PN}-speech-cmdline = " ${libdir}/${BPN}/speech/libspeech_cmdline.so "
-FILES_${PN}-speech-dbus = " ${libdir}/${BPN}/speech/libspeech_dbus.so "
-FILES_${PN}-gui-gtk = " ${libdir}/${BPN}/gui/libgui_gtk.so "
-FILES_${PN}-gui-qml = " ${libdir}/${BPN}/gui/libgui_qml.so ${datadir}/navit/skins/ "
-FILES_${PN}-gui-internal = " ${libdir}/${BPN}/gui/libgui_internal.so "
-FILES_${PN}-graphics-sdl = " ${libdir}/${BPN}/graphics/libgraphics_sdl.so "
-FILES_${PN}-graphics-qt = " ${libdir}/${BPN}/graphics/libgraphics_qt_qpainter.so "
-FILES_${PN}-graphics-gtk = " ${libdir}/${BPN}/graphics/libgraphics_gtk_drawing_area.so "
-FILES_${PN}-icons = "/usr/share/navit/xpm/"
-
-do_configure_prepend() {
- # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt
- sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in
-}
-
-do_install_append() {
- # fix QA issue
- sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop
-
- rm ${D}${libdir}/${BPN}/*/*.la
-
- #Use split config
- mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml
- install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml
- install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml
- install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml
- install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml
- install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml
-}
diff --git a/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch b/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch
deleted file mode 100644
index be41792617..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/configure.add.imlib2.option.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/configure.in.orig 2014-05-10 15:57:18.146362110 +0200
-+++ b/configure.in 2014-05-10 15:59:27.859358845 +0200
-@@ -498,10 +498,13 @@
- AC_SUBST(FRIBIDI_CFLAGS)
- AC_SUBST(FRIBIDI_LIBS)
-
-+AC_ARG_ENABLE(imlib2, [ --disable-imlib2 disable imlib2 support], imlib2=$enableval;imlib2_reason="configure parameter", imlib2=yes)
-+if test x"${imlib2}" = "xyes"; then
- PKG_CHECK_MODULES(IMLIB2, [imlib2], [imlib2_pkgconfig=yes], [imlib2_pkgconfig=no])
- if test "x$imlib2_pkgconfig" = "xyes"; then
- AC_DEFINE(HAVE_IMLIB2, 1, [Define to 1 if you have imlib2])
- fi
-+fi
- AC_SUBST(IMLIB2_CFLAGS)
- AC_SUBST(IMLIB2_LIBS)
-
diff --git a/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch b/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch
deleted file mode 100644
index 288997bca5..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/freetype-include-path.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Description: Fix FTBFS caused by freetype headers path change.
-Author: Gilles Filippini <pini@debian.org>
-Bug-Debian: http://bugs.debian.org/733378
-Index: navit/navit/font/freetype/font_freetype.c
-===================================================================
---- navit.orig/navit/font/freetype/font_freetype.c 2013-09-23 10:43:32.000000000 +0200
-+++ navit/navit/font/freetype/font_freetype.c 2013-12-30 19:54:45.000000000 +0100
-@@ -32,7 +32,7 @@
- #if USE_FRIBIDI
- #include <fribidi.h>
- #endif
--#include <freetype/ftglyph.h>
-+#include <ftglyph.h>
- #include "point.h"
- #include "graphics.h"
- #include "debug.h"
-diff -uNr navit.orig/navit/graphics/sdl/graphics_sdl.c navit/navit/graphics/sdl/graphics_sdl.c
---- navit.orig/navit/graphics/sdl/graphics_sdl.c 2012-06-22 14:16:01.000000000 +0200
-+++ navit/navit/graphics/sdl/graphics_sdl.c 2014-01-01 22:31:10.892948164 +0100
-@@ -84,7 +84,7 @@
- #else
- #include <ft2build.h>
- #include FT_FREETYPE_H
--#include <freetype/ftglyph.h>
-+#include <ftglyph.h>
- #endif
- #include <event.h>
-
diff --git a/meta-oe/recipes-navigation/navit/navit/maps.xml b/meta-oe/recipes-navigation/navit/navit/maps.xml
deleted file mode 100644
index 6f59f20c39..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/maps.xml
+++ /dev/null
@@ -1,24 +0,0 @@
- <!-- If you have the reiseplaner maps installed, set enabled="yes" in the next line and set the path correctly -->
- <mapset enabled="no">
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map"/>
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp1.smp"/>
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp2.smp"/>
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp3.smp"/>
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp4.smp"/>
- <map type="mg" enabled="yes" data="/opt/reiseplaner/travel/DE.map/smp5.smp"/>
- </mapset>
-
- <!-- If you dont want to use the sample map, either set enabled="no" in the next line or remove the xml file from the maps directory -->
- <mapset enabled="no">
- <xi:include href="$NAVIT_SHAREDIR/maps/*.xml"/>
- </mapset>
-
- <!-- Mapset template for openstreetmaps -->
- <mapset enabled="yes">
- <map type="binfile" enabled="yes" data="/media/mmc2/MapsNavit/osm_europe.bin"/>
- </mapset>
-
- <!-- Mapset template for garmin maps -->
- <mapset enabled="no">
- <map type="garmin" enabled="yes" data="/path/to/img" debug="4"/>
- </mapset>
diff --git a/meta-oe/recipes-navigation/navit/navit/navit.xml b/meta-oe/recipes-navigation/navit/navit/navit.xml
deleted file mode 100644
index 58c8c226f2..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/navit.xml
+++ /dev/null
@@ -1,45 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE config SYSTEM "navit.dtd">
-<config xmlns:xi="http://www.w3.org/2001/XInclude">
- <xi:include href="/usr/share/navit/plugins.xml"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/debug)"/>
-
- <navit center="4808 N 1134 E" zoom="256" tracking="1" orientation="-1" recent_dest="10" drag_bitmap="1">
- <graphics type="gtk_drawing_area"/>
- <gui type="gtk" enabled="no" menubar="1" toolbar="1" statusbar="1"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/gui[@type='internal'])"/>
- <!-- or comment gtk version above and try:
- opkg install navit-graphics-qt
- opkg install navit-gui-qml
- <graphics type="qt_qpainter"/>
- <gui type="qml" enabled="yes" menubar="1" toolbar="1" statusbar="1"/>
- -->
- <xi:include href="/usr/share/navit/osd.xml"/>
- <log enabled="no" type="textfile_debug" data="debug_%Y%m%d-%i.txt" flush_size="1000" flush_time="30"/>
- <vehicle name="Local GPS" profilename="car" enabled="yes" active="1" source="gpsd://localhost" gpsd_query="w+xj">
- <!-- <log type="gpx" attr_types="position_time_iso8601,position_direction,position_speed,profilename,position_radius" data="track_%Y%m%d-%i.gpx" flush_size="1000" flush_time="30"/> -->
- </vehicle>
-
- <vehicle name="Demo" profilename="car" enabled="no" active="yes" source="demo://"/>
-
- <!-- For the cumulative displacement filter to be enabled, set cdf_histsize="x" here, with x being an integer somewhere around 4 -->
- <tracking cdf_histsize="0"/>
-
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='car'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='bike'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='pedestrian'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/vehicleprofile[@name='horse'])"/>
-
- <route destination_distance="50"/>
-
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/navigation)"/>
-
- <xi:include href="/usr/share/navit/speech.xml"/>
- <xi:include href="/usr/share/navit/maps.xml"/>
-
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Car'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Car-dark'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='Bike'])"/>
- <xi:include href="/usr/share/navit/navit.default.xml" xpointer="xpointer(/config/navit/layout[@name='T@H'])"/>
- </navit>
-</config>
diff --git a/meta-oe/recipes-navigation/navit/navit/osd.xml b/meta-oe/recipes-navigation/navit/navit/osd.xml
deleted file mode 100644
index 2d0f9ffdf4..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/osd.xml
+++ /dev/null
@@ -1,15 +0,0 @@
- <!-- osd items allow to position display and control items directly on top of the map: -->
- <osd enabled="no" type="compass"/>
- <osd enabled="no" type="eta"/>
- <osd enabled="no" type="navigation_distance_to_target"/>
- <osd enabled="no" type="navigation"/>
- <osd enabled="no" type="navigation_distance_to_next"/>
- <osd enabled="no" type="navigation_next_turn"/>
-
- <!-- Commands include gui_internal_menu, gui_internal_fullscreen, zoom_in and zoom_out.
- Usage of negative values change the button origins. x="0" y="0" specifies the top left, x="-0" y="-0" the bottom right corner.
- It's always the top left corner of the icon, so you need to consider the icon's size when you enter the values. -->
- <osd enabled="no" type="button" x="0" y="0" command="gui.fullscreen()" src="toggle_fullscreen.xpm"/>
- <osd enabled="no" type="button" x="-96" y="0" command="gui.menu()" src="menu.xpm"/>
- <osd enabled="no" type="button" x="-96" y="-96" command="zoom_in()" src="zoom_in.xpm"/>
- <osd enabled="no" type="button" x="0" y="-96" command="zoom_out()" src="zoom_out.xpm"/>
diff --git a/meta-oe/recipes-navigation/navit/navit/plugins.xml b/meta-oe/recipes-navigation/navit/navit/plugins.xml
deleted file mode 100644
index 015b05517f..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/plugins.xml
+++ /dev/null
@@ -1,6 +0,0 @@
-<plugins>
- <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}lib*.so" ondemand="yes"/>
- <plugin path="$NAVIT_LIBDIR/autoload/${NAVIT_LIBPREFIX}lib*.so"/>
- <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}libbinding_dbus.so" active="yes"/>
- <plugin path="$NAVIT_LIBDIR/*/${NAVIT_LIBPREFIX}libgraphics_null.so" active="no"/>
-</plugins>
diff --git a/meta-oe/recipes-navigation/navit/navit/speech.xml b/meta-oe/recipes-navigation/navit/navit/speech.xml
deleted file mode 100644
index 28c49906d9..0000000000
--- a/meta-oe/recipes-navigation/navit/navit/speech.xml
+++ /dev/null
@@ -1,8 +0,0 @@
- <!-- Navit provides speech output in text format.
- If you have a speech synthesizer like festival lite installed, you can get turn by turn directions out of navit. Please set the "cps"-value to how many characters your tts engine approximately speaks per second.
- The default is text output to the shell -->
- <!-- <speech type="cmdline" data="echo 'Fix the speech tag in navit.xml to let navit say:' '%s'" cps="15"/> -->
- <!-- <speech type="cmdline" data="espeak -s 150 -v czech '%s' &amp;"/> -->
- <!-- <speech type="cmdline" data="flite -t '%s'"/> -->
- <!-- <speech type="cmdline" data="/usr/local/bin/say.sh '%s'"/> -->
- <speech type="cmdline" data="espeak '%s' &amp;"/>
diff --git a/meta-oe/recipes-navigation/navit/navit_svn.bb b/meta-oe/recipes-navigation/navit/navit_svn.bb
deleted file mode 100644
index bdfbb4b62e..0000000000
--- a/meta-oe/recipes-navigation/navit/navit_svn.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require navit.inc
-
-SRCREV = "5310"
-PV = "0.2.0+svnr${SRCPV}"
-PR = "${INC_PR}.3"
-
-S = "${WORKDIR}/${BPN}"
-SRC_URI += "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk;module=navit;protocol=http \
- file://freetype-include-path.patch \
- file://configure.add.imlib2.option.patch \
-"