aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gypsy
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-navigation/gypsy')
-rw-r--r--meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch114
-rw-r--r--meta-oe/recipes-navigation/gypsy/files/fixups.patch21
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy.inc25
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb15
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy_git.bb22
5 files changed, 0 insertions, 197 deletions
diff --git a/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch b/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch
deleted file mode 100644
index 063bea618d..0000000000
--- a/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-From 5b859b6e7c82f49d967c25398a8e75b61af9bcc0 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 12 Jun 2013 20:58:51 -0700
-Subject: [PATCH] g_type_init() is deprecated for glib >= 2.35.0
-
-Call it for old versions.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
----
- examples/list-known-gps-devices.c | 4 ++--
- examples/simple-gps-dbus.c | 3 ++-
- examples/simple-gps-gypsy.c | 4 ++--
- examples/simple-gps-satellites.c | 4 ++--
- gypsy/gypsy-marshal.c | 2 +-
- src/main.c | 4 ++--
- 6 files changed, 11 insertions(+), 10 deletions(-)
-
-diff --git a/examples/list-known-gps-devices.c b/examples/list-known-gps-devices.c
-index c7c4059..0a8b04b 100644
---- a/examples/list-known-gps-devices.c
-+++ b/examples/list-known-gps-devices.c
-@@ -20,9 +20,9 @@ main (int argc,
- GError *error = NULL;
- GPtrArray *known_devices;
- int i;
--
-+#if !GLIB_CHECK_VERSION(2,35,0)
- g_type_init ();
--
-+#endif
- discovery = gypsy_discovery_new ();
- known_devices = gypsy_discovery_list_devices (discovery, &error);
-
-diff --git a/examples/simple-gps-dbus.c b/examples/simple-gps-dbus.c
-index f7044e6..76b18aa 100644
---- a/examples/simple-gps-dbus.c
-+++ b/examples/simple-gps-dbus.c
-@@ -121,8 +121,9 @@ main (int argc,
- DBusConnection *conn;
- DBusError error;
- GMainLoop *mainloop;
--
-+#if !GLIB_CHECK_VERSION(2,35,0)
- g_type_init ();
-+#endif
- conn = get_connection ();
-
- dbus_error_init (&error);
-diff --git a/examples/simple-gps-gypsy.c b/examples/simple-gps-gypsy.c
-index 0b6b7a6..86033d9 100644
---- a/examples/simple-gps-gypsy.c
-+++ b/examples/simple-gps-gypsy.c
-@@ -67,9 +67,9 @@ main (int argc,
- g_print ("Usage: %s device\n", argv[0]);
- return 0;
- }
--
-+#if !GLIB_CHECK_VERSION(2,35,0)
- g_type_init ();
--
-+#endif
- control = gypsy_control_get_default ();
- path = gypsy_control_create (control, argv[1], &error);
- if (path == NULL) {
-diff --git a/examples/simple-gps-satellites.c b/examples/simple-gps-satellites.c
-index 140c98f..9a3f95a 100644
---- a/examples/simple-gps-satellites.c
-+++ b/examples/simple-gps-satellites.c
-@@ -42,9 +42,9 @@ main (int argc,
- g_print ("Usage: %s device\n", argv[0]);
- return 0;
- }
--
-+#if !GLIB_CHECK_VERSION(2,35,0)
- g_type_init ();
--
-+#endif
- control = gypsy_control_get_default ();
- path = gypsy_control_create (control, argv[1], &error);
- if (path == NULL) {
-diff --git a/gypsy/gypsy-marshal.c b/gypsy/gypsy-marshal.c
-index 6964644..9ac0095 100644
---- a/gypsy/gypsy-marshal.c
-+++ b/gypsy/gypsy-marshal.c
-@@ -5,7 +5,7 @@
-
- #ifdef G_ENABLE_DEBUG
- #define g_marshal_value_peek_boolean(v) g_value_get_boolean (v)
--#define g_marshal_value_peek_char(v) g_value_get_char (v)
-+#define g_marshal_value_peek_char(v) g_value_get_schar (v)
- #define g_marshal_value_peek_uchar(v) g_value_get_uchar (v)
- #define g_marshal_value_peek_int(v) g_value_get_int (v)
- #define g_marshal_value_peek_uint(v) g_value_get_uint (v)
-diff --git a/src/main.c b/src/main.c
-index 3e8a794..ec980e5 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -187,9 +187,9 @@ main (int argc,
- g_option_context_free (context);
-
- umask (022);
--
-+#if !GLIB_CHECK_VERSION(2,35,0)
- g_type_init ();
--
-+#endif
- mainloop = g_main_loop_new (NULL, FALSE);
-
- conn = dbus_g_bus_get (DBUS_BUS_SYSTEM, &error);
---
-1.7.9.5
-
diff --git a/meta-oe/recipes-navigation/gypsy/files/fixups.patch b/meta-oe/recipes-navigation/gypsy/files/fixups.patch
deleted file mode 100644
index de4d92ea1b..0000000000
--- a/meta-oe/recipes-navigation/gypsy/files/fixups.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
----
- docs/reference/Makefile.am | 2 ++
- 1 file changed, 2 insertions(+)
-
---- gypsy.orig/docs/reference/Makefile.am
-+++ gypsy/docs/reference/Makefile.am
-@@ -81,10 +81,12 @@ expand_content_files=
- # e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-
- INCLUDES=-I$(top_srcdir) $(GYPSY_CFLAGS)
- GTKDOC_LIBS=$(top_builddir)/gypsy/libgypsy.la $(GYPSY_LIBS)
-
-+EXTRA_DIST =
-+CLEANFILES =
- # This includes the standard gtk-doc make rules, copied by gtkdocize.
- include $(top_srcdir)/gtk-doc.make
-
- # Other files to distribute
- # e.g. EXTRA_DIST += version.xml.in
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy.inc b/meta-oe/recipes-navigation/gypsy/gypsy.inc
deleted file mode 100644
index 9efd35637b..0000000000
--- a/meta-oe/recipes-navigation/gypsy/gypsy.inc
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "GPS Multiplexing Daemon"
-DESCRIPTION = "Gypsy is a GPS multiplexing daemon which allows \
-multiple clients to access GPS data from multiple GPS sources \
-concurrently. Gypsy also hides the details of parsing NMEA from the \
-client applications, passing the data as simple values for the clients \
-to use."
-LICENSE = "GPLv2.0 & LGPLv2.1"
-SECTION = "console/network"
-DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native libxslt"
-
-PNBLACKLIST[gypsy] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
-
-inherit autotools pkgconfig gtk-doc
-PACKAGES += "libgypsy"
-
-FILES_${PN} = " \
- ${sysconfdir}/gypsy.conf \
- ${sysconfdir}/dbus-1 \
- ${libexecdir}/gypsy-daemon \
- ${datadir}/dbus-1 \
-"
-
-FILES_libgypsy = " \
- ${libdir}/libgypsy${SOLIBS} \
-"
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb
deleted file mode 100644
index 24c8987ef9..0000000000
--- a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-require gypsy.inc
-
-PR = "r2"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \
- file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \
- file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd"
-
-SRC_URI += "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \
- file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \
- "
-
-SRC_URI[md5sum] = "e2d186df9c2cc3b70a027043e22acf1a"
-SRC_URI[sha256sum] = "14e1cbe17351f408538e033ca370b4bf51ccf9c88744e236ddfb271904f154d6"
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb
deleted file mode 100644
index 6ab16e6bee..0000000000
--- a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-require gypsy.inc
-
-DEFAULT_PREFERENCE = "-1"
-
-SRCREV = "be8c9c382d2d1d37b51d29b0843045121ec90213"
-PV = "0.9+git${SRCPV}"
-PR = "r2"
-
-S = "${WORKDIR}/git"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \
- file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \
- file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd"
-
-SRC_URI += "git://anongit.freedesktop.org/gypsy \
- file://fixups.patch"
-
-do_configure_prepend() {
- # from patch 563716fc596d53f1085949a9dd11a62f39b2d624
- test -d ${S}/m4 || mkdir -p ${S}/m4
-}