aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
index f5dd62f849..20f94d5980 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -5,8 +5,17 @@ require ktap.inc
SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
DEPENDS = "ktap-module"
+#Available package configs:
+# libelf - needed to resolve symbols in DSO and for sdt
+# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
+PACKAGECONFIG ?= "libelf"
+
+PACKAGECONFIG[libelf] = ",,elfutils"
+
# Only build the userspace app
-EXTRA_OEMAKE = "ktap"
+EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+ ktap"
do_install() {
install -d ${D}${bindir}