aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb')
-rw-r--r--meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
index f075f2a3ae..c1f5f4ed8e 100644
--- a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
+++ b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
@@ -2,7 +2,8 @@ SUMMARY = " C++ binding for Wayland using the most modern C++ technology"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3aae28cc66d61975114c2b14df215407"
-SRC_URI = "git://github.com/NilsBrause/waylandpp.git;protocol=https;branch=master"
+SRC_URI = "git://github.com/NilsBrause/waylandpp.git;protocol=https;branch=master \
+ file://0001-include-missing-cstdint.patch"
DEPENDS = "pugixml"
DEPENDS:append:class-target = " waylandpp-native wayland virtual/egl virtual/libgles2"
@@ -10,7 +11,9 @@ DEPENDS:append:class-target = " waylandpp-native wayland virtual/egl virtual/lib
S = "${WORKDIR}/git"
SRCREV = "4321ed5c7b4bffa41b8a2a13dc7f3ece1191f4f3"
-inherit cmake pkgconfig
+inherit cmake pkgconfig features_check
+
+REQUIRED_DISTRO_FEATURES:class-target = "opengl"
EXTRA_OECMAKE:class-native = " \
-DBUILD_SCANNER=ON \
@@ -34,4 +37,9 @@ EXTRA_OECMAKE:class-target = " \
-DCMAKE_EXE_LINKER_FLAGS="-Wl,--enable-new-dtags" \
"
+do_install:append:class-target() {
+ sed -i -e 's|${S}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+ sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+}
+
BBCLASSEXTEND += "native nativesdk"