aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/tslib
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/tslib')
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/obsolete_automake_macros.patch16
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/ts.conf25
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/tslib.sh8
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_git.bb59
4 files changed, 0 insertions, 108 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib/obsolete_automake_macros.patch b/meta-oe/recipes-graphics/tslib/tslib/obsolete_automake_macros.patch
deleted file mode 100644
index 752077d9c1..0000000000
--- a/meta-oe/recipes-graphics/tslib/tslib/obsolete_automake_macros.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Upstream-Status: Submitted [https://github.com/kergoth/tslib/pull/14]
-
-Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
-diff --git a/configure.ac b/configure.ac
-index c42be91..6d71be0 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -6,7 +6,7 @@ AC_INIT(tslib, 1.0.0, kergoth@handhelds.org)
- # AC_CONFIG_AUX_DIR(config)
- AM_INIT_AUTOMAKE(dist-bzip2)
- AC_CONFIG_SRCDIR([src/ts_close.c])
--AM_CONFIG_HEADER(config.h)
-+AC_CONFIG_HEADERS(config.h)
-
- PACKAGE_DESCRIPTION="Touchscreen Access Library"
- AC_SUBST(PACKAGE_DESCRIPTION)
diff --git a/meta-oe/recipes-graphics/tslib/tslib/ts.conf b/meta-oe/recipes-graphics/tslib/tslib/ts.conf
deleted file mode 100644
index 1b0da937e8..0000000000
--- a/meta-oe/recipes-graphics/tslib/tslib/ts.conf
+++ /dev/null
@@ -1,25 +0,0 @@
-# Uncomment if you wish to use the linux input layer event interface
-module_raw input
-
-# Uncomment if you're using a Sharp Zaurus SL-5500/SL-5000d
-# module_raw collie
-
-# Uncomment if you're using a Sharp Zaurus SL-C700/C750/C760/C860
-# module_raw corgi
-
-# Uncomment if you're using a device with a UCB1200/1300/1400 TS interface
-# module_raw ucb1x00
-
-# Uncomment if you're using an HP iPaq h3600 or similar
-# module_raw h3600
-
-# Uncomment if you're using a Hitachi Webpad
-# module_raw mk712
-
-# Uncomment if you're using an IBM Arctic II
-# module_raw arctic2
-
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta-oe/recipes-graphics/tslib/tslib/tslib.sh b/meta-oe/recipes-graphics/tslib/tslib/tslib.sh
deleted file mode 100644
index 7068e8d922..0000000000
--- a/meta-oe/recipes-graphics/tslib/tslib/tslib.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-if [ -e /dev/input/touchscreen0 ]; then
- TSLIB_TSDEVICE=/dev/input/touchscreen0
-
- export TSLIB_TSDEVICE
-fi
-
diff --git a/meta-oe/recipes-graphics/tslib/tslib_git.bb b/meta-oe/recipes-graphics/tslib/tslib_git.bb
deleted file mode 100644
index b653978d47..0000000000
--- a/meta-oe/recipes-graphics/tslib/tslib_git.bb
+++ /dev/null
@@ -1,59 +0,0 @@
-SUMMARY = "An abstraction layer for touchscreen panel events."
-DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
-events, as well as a filter stack for the manipulation of those events. \
-Tslib is generally used on embedded devices to provide a common user \
-space interface to touchscreen functionality."
-HOMEPAGE = "http://tslib.berlios.de/"
-
-AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
-SECTION = "base"
-LICENSE = "LGPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
-
-PR = "r1"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "git://github.com/kergoth/tslib.git;protocol=git \
- file://obsolete_automake_macros.patch \
- file://ts.conf \
- file://tslib.sh"
-SRCREV = "e17263ef401ee885a27d649b90b577cfb44500e0"
-S = "${WORKDIR}/git"
-
-PV = "1.0+gitr${SRCPV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
-
-do_install_prepend() {
- install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
-}
-
-do_install_append() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
-}
-
-SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
-
-# People should consider using udev's /dev/input/touchscreen0 symlink
-# instead of detect-stylus
-#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
-RPROVIDES_tslib-conf = "libts-0.0-conf"
-
-PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
-DEBIAN_NOAUTONAME_tslib-conf = "1"
-DEBIAN_NOAUTONAME_tslib-tests = "1"
-DEBIAN_NOAUTONAME_tslib-calibrate = "1"
-
-RDEPENDS_${PN} = "tslib-conf"
-RRECOMMENDS_${PN} = "pointercal"
-
-FILES_${PN}-dbg += "${libdir}/ts/.debug*"
-FILES_${PN}-dev += "${libdir}/ts/*.la"
-FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
-FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
-FILES_tslib-calibrate += "${bindir}/ts_calibrate"
-FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"