aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb')
-rw-r--r--meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
index c45fc028fc..668ca79ddd 100644
--- a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
+++ b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.11.0.bb
@@ -1,23 +1,23 @@
DESCRIPTION = "TigerVNC remote display system"
HOMEPAGE = "http://www.tigervnc.com/"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
SECTION = "x11/utils"
DEPENDS = "xserver-xorg gnutls jpeg libxtst gettext-native fltk libpam"
-RDEPENDS_${PN} = "coreutils hicolor-icon-theme perl bash"
+RDEPENDS:${PN} = "coreutils hicolor-icon-theme perl bash xkbcomp"
LIC_FILES_CHKSUM = "file://LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
S = "${WORKDIR}/git"
-inherit features_check
+inherit autotools cmake features_check pkgconfig
+
REQUIRED_DISTRO_FEATURES = "x11 pam"
-inherit autotools cmake
B = "${S}"
SRCREV = "540bfc3278e396321124d4b18a798ac2bc18b6ca"
-SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.11-branch \
+SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.11-branch;protocol=https \
file://0002-do-not-build-tests-sub-directory.patch \
file://0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch \
file://0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch \
@@ -27,7 +27,7 @@ SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.11-branch \
XORG_PN ?= "xorg-server"
XORG_PV ?= "1.20.6"
SRC_URI += "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${XORG_PV}.tar.bz2;name=xorg"
-XORG_S = "${WORKDIR}/${XORG_PN}-${XORG_PV}"
+XORG_S = "${UNPACKDIR}/${XORG_PN}-${XORG_PV}"
SRC_URI[xorg.md5sum] = "a98170084f2c8fed480d2ff601f8a14b"
SRC_URI[xorg.sha256sum] = "6316146304e6e8a36d5904987ae2917b5d5b195dc9fc63d67f7aca137e5a51d1"
@@ -85,7 +85,7 @@ EXTRA_OECONF = "--disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DCMAKE_INSTALL_UNITDIR=${systemd_unitdir}', '-DINSTALL_SYSTEMD_UNITS=OFF', d)}"
-do_configure_append () {
+do_configure:append () {
olddir=`pwd`
cd ${XSERVER_SOURCE_DIR}
@@ -106,7 +106,7 @@ do_configure_append () {
cd $olddir
}
-do_compile_append () {
+do_compile:append () {
olddir=`pwd`
cd ${XSERVER_SOURCE_DIR}
@@ -115,7 +115,7 @@ do_compile_append () {
cd $olddir
}
-do_install_append() {
+do_install:append() {
olddir=`pwd`
cd ${XSERVER_SOURCE_DIR}/hw/vnc
@@ -124,10 +124,10 @@ do_install_append() {
cd $olddir
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${libdir}/xorg/modules/extensions \
${datadir}/icons \
${systemd_unitdir} \
"
-FILES_${PN}-dbg += "${libdir}/xorg/modules/extensions/.debug"
+FILES:${PN}-dbg += "${libdir}/xorg/modules/extensions/.debug"