aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fbida/fbida_2.09.bb')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.09.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
new file mode 100644
index 0000000000..455fd8a755
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "http://linux.bytesex.org/fbida/"
+DESCRIPTION = "frame buffer image and doc viewer tools"
+AUTHOR = "Gerd Hoffmann"
+SECTION = "utils"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+
+DEPENDS = "virtual/libiconv libpng jpeg fontconfig freetype libexif"
+
+SRC_URI = "git://git.kraxel.org/fbida"
+SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d"
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "STRIP="
+
+do_compile() {
+ sed -i -e 's: cpp: ${TARGET_PREFIX}cpp:g' GNUmakefile
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+RDEPENDS_${PN} = "ttf-dejavu-sans-mono"
+