aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb')
-rw-r--r--meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb b/meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb
new file mode 100644
index 0000000000..b503c6ed9c
--- /dev/null
+++ b/meta-oe/recipes-graphics/cglm/cglm_0.9.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenGL Mathematics Library for C"
+DESCRIPTION = "Highly optimized 2D|3D math library, also known as OpenGL Mathematics (glm) for `C`. \
+cglm provides lot of utils to help math operations to be fast and quick to write. It is community \
+friendly, feel free to bring any issues, bugs you faced."
+HOMEPAGE = "https://github.com/recp/cglm"
+BUGTRACKER = "https://github.com/recp/cglm/issues"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8dc95c4110ba741c43832734b51b7de7"
+
+SRC_URI = "git://github.com/recp/cglm;branch=master;protocol=https"
+# Tag v0.9.1
+SRCREV = "c8781615183ce3cb4f5d72caf70f2c01d7d4d2af"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG[build_tests] = "-Dbuild_tests=true,-Dbuild_tests=false,"
+
+PACKAGECONFIG ?= ""
+
+inherit meson pkgconfig
+
+EXTRA_OEMESON += "--buildtype release"
+
+BBCLASSEXTEND = "native"