aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb')
-rw-r--r--meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb b/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
index 06f3bb34cf..b8b9ef1222 100644
--- a/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
+++ b/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
@@ -17,4 +17,15 @@ DEPENDS = ""
FILES_${PN} += "${datadir}/aclocal"
FILES_${PN}-dev = ""
+# ax_code_coverage.m4 and ax_check_enable_debug.m4 are in gnome-common only
+# because older versions of autoconf-archive didn't have them yet. Now they
+# are in autoconf-archive from OE-core. We depend on that below to ensure
+# that recipes which only depend on gnome-common still get them.
+do_install_append () {
+ rm -f ${D}${datadir}/aclocal/ax_code_coverage.m4
+ rm -f ${D}${datadir}/aclocal/ax_check_enable_debug.m4
+}
+RDEPENDS_${PN} += "autoconf-archive"
+DEPENDS_append_class-native = " autoconf-archive-native"
+
BBCLASSEXTEND = "native"