aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service13
-rw-r--r--meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend16
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service
new file mode 100644
index 0000000000..18b752f154
--- /dev/null
+++ b/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Lightning Fast Webserver With Light System Requirements
+After=syslog.target
+
+[Service]
+Type=oneshot
+EnvironmentFile=-/etc/sysconfig/lighttpd
+ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend
new file mode 100644
index 0000000000..b914405b7e
--- /dev/null
+++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+PRINC = "1"
+
+SRC_URI += "file://lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${base_libdir}/systemd/systemd/
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${base_libdir}/systemd/systemd/
+
+ install -d ${D}${base_libdir}/systemd/systemd/multi-user.target.wants
+ ln -sf ../lighttpd.service ${D}${base_libdir}/systemd/systemd/multi-user.target.wants
+}
+
+FILES_${PN} += "${base_libdir}/systemd"
+