aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sanlock
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/sanlock')
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
index 9f7ce9c570..8e411e4969 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git"
DEPENDS = "libaio util-linux"
-inherit distutils
+inherit distutils3 useradd
do_configure[noexec] = "1"
@@ -32,3 +32,11 @@ do_install_prepend () {
oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
cd ${S}/python
}
+
+SANLOCKGROUP ?= "sanlock"
+SANLOCKUSER ?= "sanlock"
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system ${SANLOCKGROUP}"
+USERADD_PARAM_${PN} = "--system -g ${SANLOCKGROUP} -G disk \
+ --home-dir /run/${SANLOCKUSER} --no-create-home \
+ --shell /sbin/nologin ${SANLOCKUSER}"