aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/openlmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/openlmi')
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
index b23869d767..13e67cba12 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -21,3 +21,8 @@ do_compile_prepend() {
do_install_prepend() {
cd cli
}
+
+python() {
+ if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python to be present.')
+}