aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
new file mode 100644
index 0000000000..8fe9f3e703
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
@@ -0,0 +1,18 @@
+Use CMAKE_INSTALL_LIBDIR instead of hardcoding lib path
+
+Helps build on platforms where libpaths are not lib/ but say lib64/
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -182,7 +182,7 @@ if(NOT FLB_WITHOUT_SHARED_LIB)
+ PROPERTIES OUTPUT_NAME fluent-bit)
+
+ # Library install routines
+- install(TARGETS fluent-bit-shared LIBRARY DESTINATION lib)
++ install(TARGETS fluent-bit-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+
+ # Static Library