aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/brotli/brotli_1.1.0.bb')
-rw-r--r--meta-oe/recipes-extended/brotli/brotli_1.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb b/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
new file mode 100644
index 0000000000..83f44833b6
--- /dev/null
+++ b/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Lossless compression library and tool"
+DESCRIPTION = "Brotli is a generic-purpose lossless compression algorithm \
+that it is similar in speed to deflate but offers more dense compression."
+HOMEPAGE = "https://github.com/google/brotli"
+BUGTRACKER = "https://github.com/google/brotli/issues"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=941ee9cd1609382f946352712a319b4b"
+
+SRC_URI = "git://github.com/google/brotli.git;branch=master;protocol=https"
+SRCREV= "ed738e842d2fbdf2d6459e39267a633c4a9b2f5d"
+
+S = "${WORKDIR}/git"
+
+inherit cmake lib_package
+
+do_install:append () {
+ for lib in $(ls ${D}${libdir}/*-static.a); do
+ basename=$(basename ${lib})
+ mv -v "${lib}" "${D}${libdir}/$(echo ${basename} | sed s/-static//)"
+ done
+}
+
+BBCLASSEXTEND = "native"