aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/atftp/atftp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/atftp/atftp_git.bb')
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_git.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/atftp/atftp_git.bb b/meta-oe/recipes-extended/atftp/atftp_git.bb
index 774dd68841..67a2c1b4c5 100644
--- a/meta-oe/recipes-extended/atftp/atftp_git.bb
+++ b/meta-oe/recipes-extended/atftp/atftp_git.bb
@@ -4,6 +4,7 @@ HOMEPAGE = "http://packages.debian.org/atftp"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
PV = "0.7.1+git${SRCPV}"
+PR = "r3"
SRCREV = "be3291a18c069ae23a124ffdc56d64a5ff0bbec7"
@@ -11,10 +12,11 @@ SRC_URI = "git://atftp.git.sourceforge.net/gitroot/atftp/atftp;protocol=git \
file://atftpd-0.7_circumvent_tftp_size_restrictions.patch \
file://atftpd-0.7_unprotected_assignments_crash.patch \
file://atftpd.init \
+ file://atftpd.service \
"
S = "${WORKDIR}/git"
-inherit autotools update-rc.d useradd
+inherit autotools update-rc.d useradd systemd
INITSCRIPT_PACKAGES = "${PN}d"
INITSCRIPT_NAME_${PN}d = "atftpd"
@@ -31,10 +33,23 @@ do_install_append() {
install -d ${D}/srv/tftp
rm ${D}${sbindir}/in.tftpd
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/atftpd.service ${D}${systemd_unitdir}/system
}
PACKAGES =+ "atftpd"
FILES_${PN} = "${bindir}/*"
-FILES_${PN}d = "${sbindir}/* ${sysconfdir}/init.d/* /srv/tftp"
+FILES_${PN}d = "${sbindir}/* \
+ ${sysconfdir}/init.d/* \
+ /srv/tftp \
+ ${systemd_unitdir}/system/atftpd.service \
+"
+
+SYSTEMD_PACKAGES = "${PN}d"
+SYSTEMD_SERVICE_${PN}d = "atftpd.service"
+RPROVIDES_${PN}d += "${PN}d-systemd"
+RREPLACES_${PN}d += "${PN}d-systemd"
+RCONFLICTS_${PN}d += "${PN}d-systemd"