aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb b/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb
new file mode 100644
index 0000000000..6e61683cde
--- /dev/null
+++ b/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Tools for tracing OpenGL, Direct3D, and other graphics APIs"
+HOMEPAGE = "http://apitrace.github.io/"
+SECTION = "console/tools"
+LICENSE = "MIT & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50 \
+ file://thirdparty/snappy/COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
+
+SRCREV = "cae55f54c53449fd07f8a917dcd0874db2c15032"
+SRC_URI = "git://github.com/${BPN}/${BPN}.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "zlib libpng python3-native"
+
+inherit cmake
+
+EXTRA_OECMAKE += "\
+ -DENABLE_GUI=OFF \
+ -DENABLE_X11=OFF \
+ -DENABLE_STATIC_LIBGCC=OFF \
+ -DENABLE_STATIC_LIBSTDCXX=OFF \
+ -DPython3_ROOT_DIR=/usr/bin/python3-native \
+"
+
+# Use the bundled snappy library
+EXTRA_OECMAKE += "\
+ -DENABLE_STATIC_SNAPPY=ON \
+"