aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb')
-rw-r--r--meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb b/meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb
new file mode 100644
index 0000000000..f7160f508b
--- /dev/null
+++ b/meta-oe/recipes-devtools/systemd/nativesdk-systemd-systemctl.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Wrapper for enabling systemd services"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit nativesdk
+
+SRC_URI = "file://systemctl"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/systemctl ${D}${bindir}
+}