aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb19
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/arm/config.h21
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h17
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h21
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h17
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/trycompile.diff33
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff16
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb26
-rw-r--r--meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb34
9 files changed, 204 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb b/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb
new file mode 100644
index 0000000000..e3ecb1c089
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python template engine and code generation tool"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+SRCNAME = "Cheetah"
+PR = "r1"
+
+SRC_URI = "http://pypi.python.org/packages/source/C/Cheetah/Cheetah-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python-pickle python-pprint"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+
+SRC_URI[md5sum] = "853917116e731afbc8c8a43c37e6ddba"
+SRC_URI[sha256sum] = "be308229f0c1e5e5af4f27d7ee06d90bb19e6af3059794e5fd536a6f29a9b550"
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/config.h b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h
new file mode 100644
index 0000000000..17ef186d56
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h
new file mode 100644
index 0000000000..17ef186d56
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff
new file mode 100644
index 0000000000..3ab3d72f2c
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
+--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
++++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
+@@ -80,8 +80,7 @@
+ raise SystemError,\
+ "Non-existing %s. Perhaps you need to install"\
+ " python-dev|python-devel." % (python_h)
+- result = config_cmd.try_run(tc,include_dirs=[python_include],
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(tc)
+ if not result:
+ raise SystemError,"Failed to test configuration. "\
+ "See previous error messages for more information."
+@@ -95,7 +94,7 @@
+ if mathlib:
+ mathlibs_choices.insert(0,mathlib.split(','))
+ for libs in mathlibs_choices:
+- if config_cmd.try_run(tc,libraries=libs):
++ if config_cmd.try_compile(tc):
+ mathlibs = libs
+ break
+ else:
+@@ -180,10 +179,7 @@
+ " python-dev|python-devel." % (python_h)
+
+ config.numpy_include_dirs
+- result = config_cmd.try_run(testcode,
+- include_dirs = [python_include] + \
+- config.numpy_include_dirs,
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(testcode)
+
+ if not result:
+ raise SystemError,"Failed to generate numpy configuration. "\
diff --git a/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
new file mode 100644
index 0000000000..c5b448167f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
@@ -0,0 +1,16 @@
+--- /tmp/system_info.py 2008-08-22 00:38:16.000000000 +0200
++++ numpy-1.1.1/numpy/distutils/system_info.py 2008-08-22 00:40:33.013198000 +0200
+@@ -137,11 +137,8 @@
+ default_x11_lib_dirs = []
+ default_x11_include_dirs = []
+ else:
+- default_lib_dirs = ['/usr/local/lib', '/opt/lib', '/usr/lib',
+- '/opt/local/lib', '/sw/lib']
+- default_include_dirs = ['/usr/local/include',
+- '/opt/include', '/usr/include',
+- '/opt/local/include', '/sw/include']
++ default_lib_dirs = ['/non-existant-dir']
++ default_include_dirs = ['non-existant-dir']
+ default_src_dirs = ['.','/usr/local/src', '/opt/src','/sw/src']
+
+ try:
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb b/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb
new file mode 100644
index 0000000000..ed47f47db1
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3c42211d73c3faa1026e671dd39883fa"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
+ file://config.h \
+ file://numpyconfig.h \
+ "
+
+S = "${WORKDIR}/numpy-${PV}"
+
+inherit distutils
+
+# Make the build fail and replace *config.h with proper one
+# This is a ugly, ugly hack - Koen
+do_compile_prepend() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
+ true
+ cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
+}
+
+SRC_URI[md5sum] = "5c7b5349dc3161763f7f366ceb96516b"
+SRC_URI[sha256sum] = "2e7bb84573e5123e07f3c919fd433bc09b78d606252b6b719e385c2a981d8e06"
diff --git a/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb
new file mode 100644
index 0000000000..6b17a41f7f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+PR = "ml2"
+DEPENDS += "python"
+DEPENDS_virtclass-native += "python-native"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS_${PN} = "\
+ python-distutils \
+ python-compression \
+"
+
+SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
+SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"